Ciência da Computação Aspecto Gerais Algoritmos

NAS QUESTÕES NUMERADAS DE 11 A 25, ASSINALE A ÚNICA ALTERNATIVA QUE RESPONDE CORRETAMENTE AO ENUNCIADO.

Considerando-se os conceitos básicos de algoritmo, assinale a alternativa que apresenta o trecho correto de algoritmo para calcular a raiz de uma equação do primeiro grau (na forma ax + b = 0).

  • A.

    ...

    Leia(x)

    Leia(y)

    Se x < 0

        EntãoEscreva("Verificar dados de entrada")

    Senão

        y = -b/ax

    Fim Se

    Escreva("A raiz é", y)

    ...

  • B.

    ...

    Leia(a)

    Leia(b)

    Se a = 0 Então

       Escreva("Verificar dados de entrada")

    Senão

       x = -b/a

       Escreva("A raiz é", x)

    Fim Se

    ...

  • C.

    ...

    Leia(x)

    Leia(a)

    Leia(b)

    Se x = 0 Então

       Escreva("Verificar dados de entrada")

    Senão

       y = -b/a*x

    Fim Se

    Escreva("A raiz é", y)

    ...

  • D.

    ...

    Leia(a)

    Leia(b)

    Se a < 0 Então

       Escreva("Verificar dados de entrada")

    Senão

       x = a/b

       Escreva("A raiz é", x)

    Fim Se

    ...